Понедельник, 21.08.2017, 00:12
Приветствую Вас Гость | RSS
Главная | Баянчики - Форум | Регистрация | Вход
Новые сообщения · Участники · Правила форума · Поиск · RSS
Страница 1 из 11
Модератор форума: Buhta 
Форум » Форум » Вопросы и ответы по программам 1С » Баянчики
Баянчики
Ваш1С
1 - 16.06.2010, 15:59

просто полезные записки на память :-)
Ваш1С
2 - 16.06.2010, 15:59

//Оперучёт 7.7
//как сделать движение по регистру зная его идентификатор?

// ********************
//
Процедура ОбработкаПроведения()

Для Сч =1 По Метаданные.Регистр() Цикл
Имя = Метаданные.Регистр(Сч).Идентификатор;
Рег = СоздатьОбъект("Регистр." + Имя);
Рег.ВременныйРасчет(1);
Состояние("Заполняем регистр " + Имя + "...");
РассчитатьРегистрыПо(ДатаДок); // Рассчитываем на конец указанной даты
ТЗ = СоздатьОбъект("ТаблицаЗначений");
Рег.ВыгрузитьИтоги(ТЗ);

Рег = Регистр.ПолучитьАтрибут(Имя);

Для СчСтр = 1 по ТЗ.КоличествоСтрок() Цикл
ТЗ.ПолучитьСтрокуПоНомеру(СчСтр);
Для СчКол = 1 по ТЗ.КоличествоКолонок() Цикл
ИмяРек = ТЗ.ПолучитьПараметрыКолонки(СчКол);
Рег.УстановитьАтрибут(ИмяРек,ТЗ.ПолучитьЗначение(СчСтр,СчКол));
КонецЦикла;
Рег.ДвижениеПриходВыполнить();
КонецЦикла;
КонецЦикла;

КонецПроцедуры

Ваш1С
3 - 18.06.2010, 18:30

Базовые версии 1С (1С:Упрощёнка 8 в частности) стоят существенно дешевле версий ПРОФ не только из-за ограничения функционала:

"1С:Бухгалтерия 8.0. Базовая версия" – это однопользовательская программа для ведения бухгалтерского и налогового учета и подготовки регламентированной отчетности. По сравнению с версией ПРОФ она имеет ряд ограничений:

- не поддерживается ведение учета по нескольким фирмам в одной информационной базе; при этом имеется возможность ведения учета нескольких организаций в отдельных информационных базах на одном компьютере;
- одновременно с одной информационной базой может работать только один пользователь;
- не поддерживается изменение конфигурации, можно применять только типовую конфигурацию и устанавливать ее обновления;
- не поддерживается работа в варианте клиент-сервер;
- не поддерживается работа распределенных информационных баз;
- не поддерживается COM-соединение и Automation-сервер.

Если в организации возникнет потребность ведения многофирменного учета в единой информационной базе, одновременной работы нескольких пользователей или появятся другие задачи, которые не решаются в рамках ограничений базовой версии, то в этом случае организация сможет перейти на программу "1С:Бухгалтерия 8.0" версии ПРОФ, не имеющую указанных ограничений. Порядок апгрейда версий "1С:Бухгалтерии 8.0" описан ниже.

Но также имеют и ограничение связанное с лицензированием:

у базовых версий нет аппаратного ключа защиты. поэтому при установке программы он должен получить программную лицензию на использование программы. доступно только трехкратное получение лицензии (по почте, телефону или интернету (авторегистрация)).

если доступно - то возможна лишь трехкратная установка программы на компьютеры покупателя. при этом одновременно устанавливать и использовать программу покупатель имеет право только на одном компьютере.

первый раз лицензия получается при установке купленной программы, возможность ещё два раза получить лицензию 1С предоставляет на случай апгрейда компьютера или переустановки операционной системы. если понадобится установить программу в четвёртый раз - то её придётся покупать заново.

поэтому рекомендуется всё-таки брать 1С версии ПРОФ.

Более подробно о базовых версиях 1С можно узнать по следующим ссылкам:
http://www.1c.ru/news/info.jsp?id=5570
http://v8.1c.ru/predpriyatie/questions_licence.htm#bv1cpp
Форум » Форум » Вопросы и ответы по программам 1С » Баянчики
Страница 1 из 11
Поиск:

Copyright MyCorp © 2017